Задать вопрос
23 мая, 03:46

Напишите программу, которая по данному числу n от 1 до 9 выводит на экран n флагов. Изображение одного флага имеет размер 4*4 символов, между двумя соседними флагами также имеется пустой (из пробелов) столбец. Разрешается вывести пустой столбец после последнего флага. Внутри каждого флага должен быть записан его номер - число от 1 до n.

входные данные

1

выходные данные

+___

|1 /

|__/

|

Паскаль. Нужно использовать фор.

+4
Ответы (1)
  1. 23 мая, 04:53
    0
    Var

    i, n:integer;

    begin

    read (n) ;

    for i:=1 to n do

    write ('+___ ') ;

    writeln;

    for i:=1 to n do

    write ('|', i,' / ') ;

    writeln;

    for i:=1 to n do

    write ('|__ / ') ;

    writeln;

    for i:=1 to n do

    write ('| ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая по данному числу n от 1 до 9 выводит на экран n флагов. Изображение одного флага имеет размер 4*4 символов, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
1 Заполните пропуски числами: а) 5 Кбайт = ___ байт = ___ бит б) ___ Кбайт = ___ байт = 12288 бит в) ___ Кбайт = ___ байт = 213 бит г) ___ Гбайт = 1536 Мбайт = ___ Кбайт = ___ байт 2 Книга, набранная на компьютере, содержит 250 страниц;
Ответы (1)
Входные данные Вводится натуральное число N, которое не превосходит 30. Выходные данные Вычислите 1+2+22+23+ ...+2 N. Примеры входные данные 1 выходные данные 3 входные данные 4 выходные данные 31
Ответы (1)
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)