Задать вопрос
29 декабря, 18:04

Задача 8.11 напиши программу которая принимает с клавиатуры 2 числа 1 количество учеников в классе, 2 количество стульев в классе программа проверит соответствие между двумя соответствиями и выведет на экран соответствующие цифры например 35, 39 разделить на экран проводит 4 лишних.

+2
Ответы (1)
  1. 29 декабря, 20:54
    0
    Pascal:

    type

    cl=class

    public

    children:integer;

    f:integer;

    ff:integer;

    end;

    var

    c:cl;

    begin

    c:=new cl;

    writeln ('Введите кол-во учеников: ') ;

    read (c. children) ;

    writeln ('Введите кол-во стульев: ') ;

    read (c. f) ;

    if c. children>c. f then

    begin

    writeln ('Некорректное значение (учеников < стульев) ') ;

    Halt;

    end;

    c. ff:=c. f mod c. children;

    writeln ('Кол-во учеников: ', c. children) ;

    writeln ('Кол-во стульев: ', c. f) ;

    writeln ('Кол-во лишних стульев: ', c. ff) ;

    end.

    (Если учеников больше, чем стульев, программа закроется с уведомлением. Если учеников столько же, сколько и стульев или меньше, то напишет кол-во лишних стульев).
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача 8.11 напиши программу которая принимает с клавиатуры 2 числа 1 количество учеников в классе, 2 количество стульев в классе программа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Программа прочитает от пользователя 10 чисел, после этого выведет на экран второе самое большое число. Пример: После ввода: 5 44 80 1 8 100 11 90 2 6 Программа выведет: 90
Ответы (1)
Напишите программу, которая работает с двумя целыми числами, введёнными с клавиатуры. Программа выводит все чётные числа, расположенные в интервале между двумя введёнными числами.
Ответы (1)
Напишите программу на паскале, которая 1) сначала определит по введенному двузначному числу цифру десятков и цифру единиц. 2.1) Если цифра десятков меньше цифры единиц, то программа выведет двузначное число, состоящее из. цифр единиц.
Ответы (1)
Помогите написать программы ... Задача 1 Напишите программу, умеющую проверить положительное ли число, введённое с клавиатуры Задача 2 Напишите программу в которой из двух введенных с клавиатуры чисел, большее из них выведется на экран Задача 3
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)