Задать вопрос
3 мая, 14:33

Определить количество элементов массива, принадлежащих промежутку от a до b (значения а и b вводятся с клавиатуры; b>a) Паскаль

+4
Ответы (1)
  1. 3 мая, 14:50
    0
    Const n=20;

    var x:array[1 ... n] of integer;

    a, b, k, i:integer;

    begin

    Randomize;

    writeln ('Массив:') ;

    for i:=1 to n do begin

    x[i]:=random (51) ;

    write (x[i],' ') ;

    end;

    writeln;

    write ('a, b (a
    readln (a, b) ;

    k:=0;

    for i:=1 to n do

    if (x[i]>=a) and (x[i]<=b) then k:=k+1;

    writeln ('k = ', k) ;

    end.

    Пример:

    Массив:

    27 5 38 46 22 2 0 22 17 49 28 30 33 16 6 33 35 33 14 2

    a, b (a
    k = 8
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определить количество элементов массива, принадлежащих промежутку от a до b (значения а и b вводятся с клавиатуры; b>a) Паскаль ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
1. Найти сумму элементов массива принадлежащих промежутку от C до D (C и D вводятся с клавиатуры). 2. Определить есть ли в данном массиве положительные элементы кратные k (k вводится с клавиатуры). Паскаль
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)