Задать вопрос
13 ноября, 12:42

Задано двухзначное число. составить программу, которая отвечает на вопрос, правда ли, что все его цифры чётные

+3
Ответы (1)
  1. 13 ноября, 15:16
    0
    Program oddn;

    var

    a, b, c: integer;

    begin

    readln (c) ;

    a:=c div 10;

    b:=c - a*10;

    if (a and 1=0) and (b and 1=0) then

    writeln ('все цифры четные')

    else

    writeln ('есть нечетные цифры') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задано двухзначное число. составить программу, которая отвечает на вопрос, правда ли, что все его цифры чётные ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу: 1. Задано пятизначное число. Выделить цифры, стоящие в разряде единиц и разряде тысяч. Вывести их в порядке убывания 2. Задано четырехзначное число. Удалить из записи числа последнюю цифру.
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
Напишите программу, которая для введенной десятичной дроби выполняет сдвиг десятичной точки на указанное число разрядов (позиций) вправо (если количество разрядов задано положительное) или влево (если количество разрядов задано отрицательное).
Ответы (1)
На паскале нужно решить задачи 1. Задано трехзначное число. Составьте программу, с помощью которой определите произведение кубов цифр этого числа. 2. Задано трехзначное число.
Ответы (1)