Задать вопрос
10 февраля, 18:55

Мне нужна программа которая находит среднее арифметическое чисел вводимых в консоль.

+1
Ответы (1)
  1. 10 февраля, 21:39
    0
    Var

    n, t: integer;

    a, s: real

    begin

    readln (n) ;

    for t : = 1 to n do

    begin

    readln (a) ;

    s : = s + a;

    end;

    writeln (s / n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Мне нужна программа которая находит среднее арифметическое чисел вводимых в консоль. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
Напишите программу, которая в последовательности целых чисел находит среднее арифметическое чисел, кратных 9, или сообщает, что таких чисел нет.
Ответы (1)
20.2 (№ 987) Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое чисел, кратных 8, или сообщает, что таких чисел нет (выводит "NO").
Ответы (1)
Дано число. Если оно больше 10, то вывести на консоль, если оно меньше 3, увеличить его на 11 и вывести на консоль, в остальных случаях уменьшить на 100. PascalABC
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)