Задать вопрос
29 октября, 09:04

Pascal ...

Найти все трехзначные числа-палиндромы.

Задача с использованием repeat (обязательно)

+1
Ответы (2)
  1. 29 октября, 09:19
    0
    Var i:integer;

    begin

    i : = 100;

    repeat

    if (i mod 10 = i div 100) then

    print (i) ;

    i:=i+1;

    until (i>999) ;

    end.
  2. 29 октября, 09:24
    0
    Решение, с помощью которого не придется перебирать 800 чисел подряд:

    var

    i, j : Integer;

    begin

    i : = 1;

    repeat

    j : = 0;

    repeat

    writeln (i, j, i) ;

    j : = j + 1;

    until j = 9;

    i : = i + 1

    until i = 9

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Pascal ... Найти все трехзначные числа-палиндромы. Задача с использованием repeat (обязательно) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
В Pascal ABC необходимо: Задача 1. Вывести на экран все двузначные числа, которые нацело делятся на число, введённое пользователем. Задача 2. Даны трёхзначные натуральные числа n и k (n < k).
Ответы (1)
Петя узнал на уроке английского языка в школе о том, что существуют палиндромы - слова, которые читаются справа налево и слева направо одинаково. Придя на урок математики, он обнаружил, что число 101 тоже палиндром.
Ответы (1)
Помогите написать программы по программированию (Pascal ABC). Обязательно решать с использованием процедур. Задача 1. Написать программу, которая циклически сдвигает массив вправо или влево на указанное число позиций. Сдвиг должен быть кольцевым.
Ответы (1)