Задать вопрос
13 января, 11:52

Возвести целое число n в nнную степень. Напишите программу

+2
Ответы (1)
  1. 13 января, 15:25
    0
    Var xn, x, n, i:integer;

    begin

    write ('Введите число ') ;

    readln (xn) ;

    write ('Введите степень числа ') ;

    readln (n) ;

    x:=xn;

    for i:=1 to n-1 do

    begin

    x:=x*xn;

    end;

    writeln (x) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Возвести целое число n в nнную степень. Напишите программу ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Число 712 возвести в двоичную систему счисления и обратно число 712 возвести в восьмеричную систему счисления и обратно число 712 возвести в шестнадцатеричную систему счисления
Ответы (1)
Дано целое число если оно положительное то возвести его в квадрат иначе возвести третьей степень
Ответы (1)
Программа на языке паскаль. ввести с клавиатуры целое число, если оно положительное возвести его в квадрат, если отрицательное возвести в четвёртую степень. Напечатать результат на экране
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Напиши программу. Дано целое число N (N > 0). Найти сумму (N + 1) ^2 + (N + 2) ^2 + ... + (2•N) ^2 Входные данные: ввести целое число N (1
Ответы (1)