Задать вопрос
3 декабря, 14:26

Паскаль. Известно, что первые два элемента массива равны a и b. А каждый следующий элемент равен сумме значений всех предыдущих элементов и собственного номера (нумерация элементов массива начинается с единицы). Заполните массив из n элементов, используя этот принцип и выведите значения элементов массива в обратном порядке.

Формат входных данных

Целые положительное число n (2

Целые числа a, b (-50 < a, b < 50)

Формат выходных данных

Строка, содержащая элементы искомого массива в обратном порядке, записанные через пробел

+1
Ответы (1)
  1. 3 декабря, 14:55
    0
    Var n, a, b, i, j: integer;

    ar: array[1 ... 10000]of integer;

    begin

    read (n, a, b) ;

    ar[1] : = a;

    ar[2] : = b;

    for i : = 3 to n do

    begin

    for j : = 1 to i - 1 do

    begin

    ar[i] : = ar[i] + ar[j];

    end;

    ar[i] : = ar[i] + i;

    end;

    for i : = n downto 1 do write (ar[i],' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль. Известно, что первые два элемента массива равны a и b. А каждый следующий элемент равен сумме значений всех предыдущих элементов и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан массив целых чисел. Нумерация элементов начинается с 0. Выведите все элементы массива с четными номерами. Формат входных данных Сначала задано число N - количество элементов в массиве, N100. Далее через пробел записаны N чисел - элементы массива.
Ответы (1)
1. заполните одномерный массив B1 размерностью в N (< 30 задает пользователь при выполнении программы) элементов так, чтобы каждый элемент с четным номером был равен половине своего номера, а каждый элемент с нечетным номером - количеству элементов
Ответы (1)
Паскаль Формат входных данных Сначала задано число N - количество элементов в массиве (1N35). Далее через пробел записаны N чисел - элементы массива. Формат выходных данных Необходимо вывести значение наибольшего элемента в массиве.
Ответы (1)
С # 1. Создайте одномерный массив с 31 элементов, которые заполните случайными целыми числами от 11 до 100-11. Выведите значения элементов массива в строку, разделив их пробелами, 11 нечетное число.
Ответы (1)
H. Работа с несколькими массивами Дан массив a, состоящий из n целых чисел. Ваша задача - переписать его элементы в другой массив такого же размера следующим образом: сначала должны идти все отрицательные элементы, а затем все остальные.
Ответы (1)