Задать вопрос
4 февраля, 14:26

Паскаль. Напишите программу, которая по последней цифре числа определяет последнюю цифру квадрата этого числа

+4
Ответы (2)
  1. 4 февраля, 15:29
    0
    Var a, b: longint;

    begin

    write ('введите число - > ') ;

    readln (a) ;

    a:=a mod 10;

    b: = (a*a) mod 10;

    writeln ('последняя цифра квадрата числа - > ', b) ;

    end.
  2. 4 февраля, 17:54
    0
    Var i: Integer;

    begin

    write ('Число: ') ;

    readLn (i) ;

    i : = i mod 10;

    writeLn ('Цифра квадрата = ',

    sqr (i) mod 10) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль. Напишите программу, которая по последней цифре числа определяет последнюю цифру квадрата этого числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль! Написать программу, в которой по последней цифре числа определить последнюю цифру его квадрата и последнюю цифру его куба. Для определения последней цифры числа применить операцию MOD (получение остатка от деления).
Ответы (1)
Напишите программу которая по последней цифре числа определяет последнюю цифру квадрата этого числа
Ответы (1)
Напишите программу, позволяющую по последней цифре трехзначного числа определить последнюю цифру его произведения на число 3 (например, для числа 234, последней цифрой при произведении на 3 будет цифра 2)
Ответы (1)
Домашнее задание: 1. Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет сумму и произведение его цифр. 2.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)