Задать вопрос
22 ноября, 11:42

Дан числовой массив А состоящий из n элементов если отношение числа положительных элементов к числу отрицательных более 2, то все отрицательные элементы этого массива замените на 1, а положительные умножьте на максимальный элемент

+5
Ответы (1)
  1. 22 ноября, 14:36
    0
    Const

    n=15;

    var

    i, np, nn, amax:integer;

    a:array[1 ... n] of integer;

    begin

    Randomize;

    Write ('Исходный массив: ') ;

    np:=0; nn:=0;

    for i:=1 to n do begin

    a[i]:=Random (51) - 15;

    Write (a[i],' ') ;

    if a[i]>0 then Inc (np)

    else if a[i]<0 then Inc (nn) ;

    end;

    Writeln;

    if np/nn>2 then begin

    amax:=a[i];

    for i:=2 to n do

    if a[i]>amax then amax:=a[i];

    Write ('Выходной массив: ') ;

    for i:=1 to n do begin

    if a[i]<0 then a[i]:=1

    else

    if a[i]>0 then a[i]:=a[i]*amax;

    Write (a[i],' ')

    end;

    Writeln

    end

    else Writeln ('В массив изменения не вносятся')

    end.

    Пример работы программы

    Исходный массив: 28 8 21 32 0 26 30 11 35 21 14 6 0 - 4 - 8

    Выходной массив: 980 280 735 1120 0 910 1050 385 1225 735 490 210 0 1 1
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан числовой массив А состоящий из n элементов если отношение числа положительных элементов к числу отрицательных более 2, то все ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
Дан одновременный массив, состоящий из 10 эллементов. Пользователь вводит элементы массива. Ввести массив на экран в строку. Найти минимальный элемент массива.
Ответы (1)