Задать вопрос
10 апреля, 22:21

Помогите!

Помогите решить!

1) Какие из описаний могут быть именами переменных

a) 4_с

b) sum

c) b 3

d) one_а

2) Какая команда в Pascal-е служит для того, чтобы задать какой-либо переменной значение до выполнения алгоритма? Приведите пример.

3) Найдите и исправьте ошибки в следующей программе:

program prim_a;

var m, n, k: integer;

writeln ('введите значения переменных m и n') ;

red (m, n, k) ;

writeln (m+n+k) ;

end.

4) Напишите программу для решения одной из двух задач:

a) Найти площадь и периметр прямоугольника со сторонами а и b.

b) Найти значение выражения:

5) Напишите программу для нахождения суммы крайних цифр трехзначного числа.

+3
Ответы (1)
  1. 11 апреля, 01:57
    0
    1)

    a) не может, потому что переменные должны всегда начинаться с буквы

    b) может

    c) не может, слова могут быть разделены только знаком "_", не пробелом!

    d) может

    2) присваивание, обозначается знаком "="

    Например:

    sum = 0;

    3)

    4 строка - не red, а read

    пропущена трока между 2 и 3 строчкой - это begin

    4)

    var

    S, P, a, b: integer

    begin

    write ('Введите сторону а: ') ;

    readln (a) ;

    write ('Введите сторону b: ') ;

    readln (b) ;

    S = a * b; {нахидим площадь}

    P = (a + b) * 2; {находим периметр}

    writeln ('Площадь = ', S, ', периметр = ', P) ;

    end.

    5)

    Var

    number, {Трехзначное число}

    num1, {Первая крайняя цифра}

    num2, {Вотрая крайняя цифра}

    : integer;

    Begin

    write ('Введите число') ;

    readln (number) ;

    num1 = number mod 10;

    num2 = number div 100;

    writeln ('Сумма крайних цифр числа ', number, ' = ', num1 + num2) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите! Помогите решить! 1) Какие из описаний могут быть именами переменных a) 4_с b) sum c) b 3 d) one_а 2) Какая команда в Pascal-е ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить! 1) Какие из описаний могут быть именами переменных a) 4_с b) sum c) b 3 d) one_а 2) Какая команда в Pascal-е служит для того, чтобы задать какой-либо переменной значение до выполнения алгоритма? Приведите пример.
Ответы (1)
Сделать так чтобы Writeln был заменен другим словом и повторялься не больше двух раз program choise; var N_M:integer; writeln (' введи номер месяца ') ; readln (N_M) ; case N_M of 1:writeln (' январь ') ; 2:writeln (' февраль ') ;
Ответы (1)
Найдите и исправьте ошибки в следующей программе: program prim_a; var m, n, k:integer; writeln (введите значение переменных m и n) ; red (n, n, k) ; writeln (m+n+k) ; end
Ответы (1)
Program pr_1; var x, y, sum, umn: integer; begin write ('x=') ; readln (x) ; write ('y=') ; readln (y) ; sum:=x+y; umn:=x*y; writeln ('sum=', sum) ; writeln ('umn=', umn) ; readln; end. x=25 y=36 sum=? umn=?
Ответы (1)
Укажите области видимости в программе: Program P; Var x: integer; Procedure P1; Var y: integer; Begin P2; End; Procedure P2; Var z: integer; Begin {Тело процедуры} End; Procedure P3; Var m: integer; Begin P1; End; Begin {Тело основной программы}P3;
Ответы (1)