Задать вопрос
16 июня, 05:15

2) Дано целое число. Определить

- а) является ли оно четным

- б) оканчивается ли нон цифрой 7

-в) оканчивается ли оно четной цифрой. Составное условие не используется.

+4
Ответы (1)
  1. 16 июня, 05:36
    0
    Var

    a, b : integer;

    begin

    b : = 0;

    readln (a) ;

    if a mod 2 = 0 then writeln ('Число четное') ;

    else writeln ('Число нечетное') ;

    b : = a mod 10;

    if b = 7 then writeln ('Число заканчивается на 7') ;

    else writeln ('Число не заканчивается на 7') ;

    if b mod 2 = 0 then writeln ('Число оканчивается четным числом') ;

    else writeln ('Число не оканчивается черным числом') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «2) Дано целое число. Определить - а) является ли оно четным - б) оканчивается ли нон цифрой 7 -в) оканчивается ли оно четной цифрой. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано целое число. Определить, является оно четным или не четным
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
1) Определить, является ли введенное с клавиатуры число четным? 2) Дано целое число. Если оно является положительным, то прибавить к нему 1; если отрицательным, то вычесть из него 2; если нулевым, то заменить его на 10. Вывести полученное число.
Ответы (1)
Решить задачи: 1. Дано целое число. Если оно является положительным, то прибавить к нему 8, если нет, то не изменять. Вывести полученное число. 2. Дано целое чило.
Ответы (1)
Напишите программу по выдаче рандомных чисел, содержащих от 1 до 5 знаков, состоящих из чисел от 1 до 12, так чтобы: За цифрой 1 могли следовать только цифры 4, 5, 7, 9, 10 За цифрой 2 - только 5, 6, 8, 10, 11 За цифрой 3 - только 6, 7, 9, 11, 12 За
Ответы (1)