Задать вопрос
24 сентября, 07:35

Помогите написать задачу на паскале или на чем вам удобнее

Автобус прибывает на станцию в a часов b минут и отправляется в c часов d минут. Пассажир пришел в n часов m минут. Будет ли автобус находиться на станции? Формат ввода Во входных данных программе даются 6 целых чисел a, b, c, d, n, m, 0 ≤ a ≤ 23, 0 ≤ b ≤ 59, 0 ≤ c ≤ 23, 0 ≤ d ≤ 59, 0 ≤ n ≤ 23, 0 ≤ m ≤ 59

+1
Ответы (1)
  1. 24 сентября, 07:56
    0
    Var a, b, c, d, n, m:integer.;

    Begin

    clrscr;

    Writeln ('Time:') ;

    Readln (a) ;

    Readln (b) ;

    Writeln ('Time end. ') ;

    Readln (c) ;

    Readln (d) ;

    Writeln (' People ') ;

    Realn (n) ;

    Readln (m) ;

    {

    Тут сам сделай проверку через If если не входит в условие то ошибку чтобы выдавало

    }

    {

    сделай проверку если человек в промежутке между остановками то ответ да. Иначе нет

    }

    Readkey;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать задачу на паскале или на чем вам удобнее Автобус прибывает на станцию в a часов b минут и отправляется в c часов d минут. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите на пасхале Задача: Найти количество четных цифр натурального числа. Формат ввода: На вход подается натуральное, не превосходящее 30000. Формат вывода: Целое число. Пример входных данных 321 Пример выходных данных 1
Ответы (1)
С некоторого момента прошло N дней. Сколько полных недель прошло за этот период. Формат входных данных На вход программе подается 0≤N≤106. Формат выходных данных Вывести целое число - ответ на вопрос. Примеры: Вход 100 Выход 14
Ответы (1)
Задача D Нечет Задано два целых числа A и B. Найдите сумму нечетных чисел от A до B. Формат входных данных Первая строка входного файла содержит два целых числа A и B (1 < = A, B < = 10^9). Формат выходных данных Выведите ответ к задаче.
Ответы (1)
Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N. Формат входных данных Задано единственное число N. Формат выходных данных Необходимо вывести все точные квадраты натуральных чисел, не превосходящие данного числа N.
Ответы (1)
Задача D Три числа Дан массив из N целых чисел а1, а2, ..., an. Вам нужно проверить, есть ли в этом массиве три числа сумма которых равна нулю. Формат входных данных В первой строке входного файла содержится одно целое число N (1 ≤ N ≤ 2000).
Ответы (1)