Задать вопрос
17 апреля, 01:08

Даны 2 числа. Если они оба отрицательные, то вывести их модуль, если они оба положительные, то возвести их в квадрат.

+2
Ответы (1)
  1. 17 апреля, 02:38
    0
    Program pp;

    var a, b:integer;

    begin

    read (a, b) ;

    if (a>0) and (b>0) then begin

    a:=sqr (a) ;

    b:=sqr (b) ;

    end;

    if (a<0) and (b<0) then begin

    a:=abs (a) ;

    b:=abs (b) ;

    end;

    writeln (a, b) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны 2 числа. Если они оба отрицательные, то вывести их модуль, если они оба положительные, то возвести их в квадрат. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу на языке Паскаль если два числа положительные, то возвести оба числа в квадрат если оба числа отрицательные, то найти их модуль
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
2. Даны три целых числа. Возвести в квадрат отрицательные числа и в третью степень - положительные (число 0 не изменять).
Ответы (1)
С клавиатуры вводится два трехзначных числа. Возвести первое число в квадрат, а из второго извлечь корень, если хотя бы у одного из чисел, средняя цифра четная. В противном случае из первого извлечь корень, а второе возвести в квадрат.
Ответы (2)
Число 712 возвести в двоичную систему счисления и обратно число 712 возвести в восьмеричную систему счисления и обратно число 712 возвести в шестнадцатеричную систему счисления
Ответы (1)