Задать вопрос
25 марта, 07:42

2. Даны три целых числа. Возвести в квадрат отрицательные числа и в третью степень - положительные (число 0 не изменять).

+4
Ответы (1)
  1. 25 марта, 09:06
    0
    Var a, b, c: integer;

    function zd (a:integer) : integer;

    begin

    if a=0 then

    zd:=0

    else

    if a>0 then zd:=sqr (a) else zd:=a*a*a;

    end;

    begin

    read (a, b, c) ;

    write (zd (a), ' ') ;

    write (zd (b), ' ') ;

    write (zd (c), ' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «2. Даны три целых числа. Возвести в квадрат отрицательные числа и в третью степень - положительные (число 0 не изменять). ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Число 712 возвести в двоичную систему счисления и обратно число 712 возвести в восьмеричную систему счисления и обратно число 712 возвести в шестнадцатеричную систему счисления
Ответы (1)
Даны 2 числа. Если они оба отрицательные, то вывести их модуль, если они оба положительные, то возвести их в квадрат.
Ответы (1)
Даны три действительных числа. Возвести в квадрат те из них, значения которых неотрицательны, и в четвертую степень - отрицательные. Писать нужно на паскале.
Ответы (1)
Напишите программу. Даны три действительных числа. Возвести в квадрат те из них, значения которых неотрицательны, и в четвертую степень - отрицательные.
Ответы (1)
С клавиатуры вводится два трехзначных числа. Возвести первое число в квадрат, а из второго извлечь корень, если хотя бы у одного из чисел, средняя цифра четная. В противном случае из первого извлечь корень, а второе возвести в квадрат.
Ответы (2)