Задать вопрос
7 января, 10:09

Составьте программу вычисления функции y=sinx2^n используйте подпрограмму, функцию для ее вычисления

+3
Ответы (2)
  1. 7 января, 12:17
    0
    Var x, y:real; n:integer;

    function f (x:real; n:integer) : real;

    var i, st:integer;

    begin

    st:=1;

    for i:=1 to n do st:=st*2;

    f:=sin (x) * st;

    end;

    begin

    writeln ('x, n:') ;

    readln (x, n) ;

    y:=f (x, n) ;

    writeln ('x = ', x,' y = ', y) ;

    end.

    Пример:

    x, n:

    2 5

    x = 2 y = 29.0975176584218
  2. 7 января, 13:12
    0
    Program sinus;

    var x, y:real;

    begin

    writeln ('введите число') ;

    readln (x) ;

    y:=sin (x) * 2*2;

    writeln (y) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу вычисления функции y=sinx2^n используйте подпрограмму, функцию для ее вычисления ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Даны основания и высоты двух трапеций. Составьте программу для вычисления суммы их площадей. Используйте подпрограмму вычисления площади одной трапеции. а=2, в=3, h=2.5 а=4.1, в=5, h=3.3
Ответы (1)
Нужно сделать подпрограмму. Помогите не умею я подпрограммы писать! 9 класс, Делфи Сделать подпрограмму, которая вводит с клавиатуры 3 числа, находит найбольшее и выводит на экран.
Ответы (1)
Разработать подпрограмму, которая в качестве аргумента получает целое число и проверяет, является ли оно простым. Используя подпрограмму вывести на экран все простые числа из промежутка целых чисел, определенного пользователем. Pascal ABC
Ответы (1)
1) Составьте программу вычисления сумму чисел от 1 до 100. 2) Составьте программу вычисления произведения чётных чисел от 1 до 10. 3) Составьте программу вычисления количества двухзначных нечётных чисел.
Ответы (1)
Составьте программу вычисления площади кольца по значениям внутреннего и внешнего радиусов, используя подпрограмму вычисления площади круга (два варианта: с процедурой и с функцией)
Ответы (1)