Задать вопрос
2 августа, 21:37

Pascal, цикл для, составить программу.

2) Составить программу, запрашивающую пароль пользователя. В случае правильности пароля выводится фраза: "Можно приступать к работе". Если пароль 3 раза введен неверно, то вывести "Вызываю охрану"

+3
Ответы (1)
  1. 3 августа, 00:08
    0
    Var pass, s:string; k:integer;

    begin

    pass:='12345';

    k:=0;

    repeat

    writeln ('Введите пароль:') ;

    readln (s) ;

    k:=k+1;

    until (s=pass) or (k=3) ;

    if s=pass

    then writeln ('Можно приступать к работе')

    else writeln ('Вызываю охрану') ;

    end.

    Пример:

    Введите пароль:

    1

    Введите пароль:

    12345

    Можно приступать к работе
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Pascal, цикл для, составить программу. 2) Составить программу, запрашивающую пароль пользователя. В случае правильности пароля выводится ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Пароль Игорь придумал пароль из 16 символов, состоящий из цифр и английских букв. Чтобы его не забыть, он решил записать пароль, но предварительно хочет его зашифровать.
Ответы (1)
Ввести с клавиатуры пароль (символьную строку). Если его длина меньше, чем 6 символов, вывести сообщение "Слишком короткий пароль!". Если пароль начинается с букв "qwerty" вывести сообщение "Ненадёжный пароль!".
Ответы (1)
Решить задачу с помощью цикла с предусловием 1) Организовать проверку пароля, если пароль верный - написать "Вход в систему разрешен", если пароль не угадан 5 раз - прекратить проверку пароля. 2) Ввести целое число и найти сумму его цифр.
Ответы (2)
Напишите программу, которая "спрашивает" пароль для входа в систему, а после введения пользователем пароля и нажатия кнопки ОК выводит окно со значком критической ошибки и сообщением о том, что был введён неправильный пароль.
Ответы (1)
1) Разработайте программу, запрашивающую у пользователя длины обеих катетов прямоугольного треугольника, и выводящую на экран гипотезу по формуле Пифагора 2) Запросите у пользователя длину ребра куба, Найдите и выведите на экран площадь одной грани,
Ответы (1)