Задать вопрос
23 февраля, 04:32

Pascal, цикл для, составить программу

Ввести целое число N. Найти сумму первых N чётных натуральных чисел.

+4
Ответы (1)
  1. 23 февраля, 05:08
    0
    Var n, i, s:integer;

    begin

    write ('n = ') ;

    readln (n) ;

    s:=0;

    for i:=1 to n do s:=s+2*i;

    writeln ('s = ', s) ;

    end.

    Пример:

    n = 5

    s = 30
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Pascal, цикл для, составить программу Ввести целое число N. Найти сумму первых N чётных натуральных чисел. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу, которая вводит натуральное число N и нахо дит сумму всех натуральных чисел от 1 до N. Используйте сначала цикл с условием, а потом - цикл с переменной.
Ответы (1)
Программирование в python 3 Напечатать массив и сумму его первых N десятков. Пример: Пользователь вводит любое число, например 56 Программа выдаёт на экран массив от 0 до 55 и ещё пять чисел: сумму первых 10, сумму первых 20, сумму первых 30, сумму
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Напиши программу. Дано целое число N (N > 0). Найти сумму (N + 1) ^2 + (N + 2) ^2 + ... + (2•N) ^2 Входные данные: ввести целое число N (1
Ответы (1)