Задать вопрос
7 июня, 19:00

Дано 3 значное число. Найдите 1) Среднее арифметическое и его цифры. 2) Сумму квадратов его цифр.

+4
Ответы (1)
  1. 7 июня, 20:08
    0
    Var n, sum, sum2, d, ind, i, j:integer; sred : double;

    begin

    Write ('n') ;

    Readln (n) ;

    d:=1;

    ind:=3;

    sum:=0; sum2:=0; sred:=0;

    for i:=0 to ind-1 do

    begin

    sum:=sum + (n div d) mod 10;

    sred:=sum/3;

    sum2:=sum2 + sqr ((n div d) mod 10) ;

    d:=10*d;

    end;

    Writeln ('suma ', Sum) ;

    Writeln ('Sum 2 ', sum2) ;

    writeln ('Sred ', sred:0:5) ;

    //Writeln ('вывод цифр') ;

    d:=1;

    for i:=0 to ind-1 do

    begin

    writeln ((n div d) mod 10) ;

    d:=10*d;

    end;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано 3 значное число. Найдите 1) Среднее арифметическое и его цифры. 2) Сумму квадратов его цифр. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
1. Дано трехзначное число. Найти число единиц в нем число десятков в нем сумму его цифр произведение его цифр 2. Дано трехзначное число. Найти число. Найти число, полученное при прочтении его цифр справа налево
Ответы (1)
Дано четырех значное число. Нужно проверить является ли сумма цифр заданного числа. Формат ввода: в входном файле находится одно четырех значное число.
Ответы (1)