Задать вопрос
21 сентября, 04:22

Программа на Паскале. Составить программу превода натурального числа N из 10 системы счисления в 8 систему счисления через рекурсию. Что число натуральное, проверять не надо. Если что то не понятно, спрашивайте.

+3
Ответы (1)
  1. 21 сентября, 05:09
    0
    Begin

    if n > 1 then

    decTo5 (n div 5) ;

    write (n mod 5) ;

    end;

    var n: integer;

    begin

    write ('n = ') ;

    readLn (n) ;

    if (n > 0) then

    decTo5 (n)

    else

    writeLn ('Error, n must > 0!') ;

    writeLn;

    end.

    Извини меня если не правильно. Вроде так.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Программа на Паскале. Составить программу превода натурального числа N из 10 системы счисления в 8 систему счисления через рекурсию. Что ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу на Pascal, используя рекурсию: Дан набор символов, оканчивающихся пробелом (короче это слово), Вывести символы в обратном порядке, используя рекурсию.
Ответы (2)
1.11010101,00011 переведите число из двоичной в десятичную систему счисления 2.10111101,110111 переведите число из двоичной в восьмиричную систему счисления 3.101100010100,1011 переведите число из двоичной в шестнадцатиричную систему счисления 4.
Ответы (1)
7. Под основанием системы счисления понимают: a) количество используемых знаков в алфавите системы счисления; b) наибольшую цифру в алфавите системы счисления; c) название системы счисления;
Ответы (1)
1) Десятичное число 4563 в двоичной системе счисления равно 2) Десятичное число 800 в восьмеричной системе счисления равно 3) Десятичное число 781 в шестнадцатеричной системе счисления равно 4) Двоичное число 1000000 в десятичной системе счисления
Ответы (1)
5. Системы счисления. a. Переведите данное число из десятичной системы счисления в двоичную, восьмеричную и шестнадцатеричную системы счисления: 114,22510 b. Переведите данные числа в десятичную систему счисления: 100111100,11012 1234,58 2B3, F416 c.
Ответы (1)