Задать вопрос
17 июня, 13:13

Написать программу на Pascal, используя рекурсию:

Дан набор символов, оканчивающихся пробелом (короче это слово), Вывести символы в обратном порядке, используя рекурсию.

+2
Ответы (2)
  1. 17 июня, 14:54
    0
    Var s: string;

    procedure PrintChar (s:string; n:integer) ;

    begin

    if s[n]' '

    then begin PrintChar (s, n+1) ; write (s[n]) ; end;

    end;

    begin

    write ('Введите слово: ') ;

    readln (s) ;

    PrintChar (s, 1) ;

    end.

    Пример:

    Введите слово: телефон

    нофелет
  2. 17 июня, 16:19
    0
    Program pos;

    var

    s: string;

    l: integer;

    procedure PrintChar (n: integer) ;

    var

    sub: string;

    begin

    sub : = Copy (s, n, 1) ;

    write (sub) ;

    if n 1 then

    PrintChar (n - 1) ;

    end;

    begin

    write ('Введите слово: ') ;

    readln (s) ;

    l : = Length (s) ;

    PrintChar (l) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на Pascal, используя рекурсию: Дан набор символов, оканчивающихся пробелом (короче это слово), Вывести символы в ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Файл input. txt: Мама, короче, мыла, короче, раму. Декан, короче, пропил, короче, бутан. А роза, короче, упала на лапу, короче, Азора. Каждый, короче, охотник желает, короче, знать, где короче сидит фазан В файле input.
Ответы (1)
1. Сформировать текст заданной длины, состоящий из 2 символов А и В. 2. Найдите количество символов заданного числа 25 3. Написать программу обращения заданного слова (вывести символы строки в обратном порядке). (слово привет) 4.
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
Паскаль АВС. Дана строка символов. Составьте программу которая подсчитывает, сколько в данной строке слов оканчивающихся на а. Все слова разделяются 1 пробелом и только русские буквы.
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)