Задать вопрос
27 июня, 07:21

Надо написать программу

Вычислите N! ("эн-факториал") - произведение всех натуральных чисел от 1 до N (N!=1∙2∙3∙ ...∙ N).

Входные данные

Вводится единственное число N - натуральное, не превосходит 12.

Выходные данные

Выведите полученное значение N!

Примеры

входные данные

2

выходные данные

2

входные данные

3

выходные данные

6 (На Паскале) Буду благодарен

+4
Ответы (2)
  1. 27 июня, 07:40
    0
    Program fact;

    var

    n, f, i: integer;

    begin

    f : = 1;

    readln (n) ;

    for i : = 2 to n do

    f : = f * i;

    writeln (f) ;

    end.
  2. 27 июня, 09:05
    0
    Var b, i, k, n: int64;

    begin

    readln (n) ;

    b:=1;

    for i : = 1 to n do

    b:=b*i;

    writeln (b) ;

    end.

    Входные данные подставлять в переменную n
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Надо написать программу Вычислите N! ("эн-факториал") - произведение всех натуральных чисел от 1 до N (N!=1∙2∙3∙ ...∙ N). Входные данные ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Входные данные Вводится натуральное число N, которое не превосходит 30. Выходные данные Вычислите 1+2+22+23+ ...+2 N. Примеры входные данные 1 выходные данные 3 входные данные 4 выходные данные 31
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)
Напишите программу, вычисляющую 2^N. Входные данные Вводится целое неотрицательное число N, которое не превосходит 30. Выходные данные Выведите число 2^N.
Ответы (1)