Задать вопрос
31 марта, 14:57

Программа нужна на паскале

С кондитерской фабрики отгружают конфеты в коробках по 7 кг, 5 кг, 3 кг и 1 кг. Какое наименьшее количество коробок потребуется для перевозки N килограмм

+5
Ответы (1)
  1. 31 марта, 18:57
    0
    Var n, k7, k5, k3, k1, k:integer;

    begin

    write ('n = ') ;

    readln (n) ;

    k7:=n div 7;

    k5: = (n-k7*7) div 5;

    k3: = (n-k7*7-k5*5) div 3;

    k1:=n-k7*7-k5*5-k3*3;

    writeln ('k7 = ', k7,' k5 = ', k5,' k3 = ', k3,' k1 = ', k1) ;

    writeln ('k = ', k7+k5+k3+k1) ;

    end.

    Пример:

    n = 20

    k7 = 2 k5 = 1 k3 = 0 k1 = 1

    k = 4
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Программа нужна на паскале С кондитерской фабрики отгружают конфеты в коробках по 7 кг, 5 кг, 3 кг и 1 кг. Какое наименьшее количество ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
С кондитерской фабрики отгружают конфеты в коробках по 7 кг, 5 кг, 3 кг и 1 кг. Какое наименьшее количество коробок потребуется для перевозки N килограмм конфет?
Ответы (1)
Назови одним словом. - Легковой автомобиль для перевозки пассажиров. - Автомобиль для перевозки грузов. - Судно для перевозки пассажиров. - Судно для перевозки нефти. - Судно для ловли рыбы. - Поезд для перевозки пассажиров.
Ответы (1)
Составить программу решающую задачу: С конца терской фабрики отгружают конфеты в коробках по 10 кг, 5 кг и 1 кг какое наименьшее кол-во короьок потребуеться для перевозки N кг конфет
Ответы (1)
7 класс. Turbo Pascal Задача №1: С кондитерской фабрики разгружают конфеты в коробках по 10 кг, 5 кг и 1 кг.
Ответы (1)
Помогите сделать программу в Паскале В котором 1) Программа выдает сообщение "Вы маль или дево" 2) Пользователь в переменную ST1 задает значение маль или дево 3) Программа выдает сооб "Ты пошла бы играть в куклы" 4) Вводить ответ через переменную
Ответы (1)