Задать вопрос
5 февраля, 13:04

Написать в Pascal программу, которая сможет сделать следующее:

+2
Ответы (2)
  1. 5 февраля, 13:59
    0
    Var x, i, n, s: longint; / / объявление переменных

    begin s : = 0; / / изначально сумма равна 0

    read (x, n) ; / / ввод x, n

    for i : = 1 to n do s : = s + trunc (power (x, i)) ; / / n раз

    //прибавляем к сумме x в i

    //степени (power)

    write (s) ; / / выводим сумму

    end.
  2. 5 февраля, 15:54
    0
    Var x, s, p:real; i, n: integer;

    begin

    write ('x = ') ;

    readln (x) ;

    write ('n = ') ;

    readln (n) ;

    p:=1; s:=0;

    for i:=1 to n do

    begin

    p:=p*x;

    s:=s+p;

    write (x,'^', i) ;

    if in then write (' + ') else write (' = ') ;

    end;

    writeln (s) ;

    end.

    Пример:

    x = 2

    n = 5

    2^1 + 2^2 + 2^3 + 2^4 + 2^5 = 62
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать в Pascal программу, которая сможет сделать следующее: ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Преобразуйте следующее двоичное число в восьмеричное: 10011 2) Преобразуйте следующее двоичное число в десятеричное: 101100 3) Преобразуйте следующее двоичное число в шестнадцатеричное: 1011000111 4) Преобразуйте следующее восьмеричное число в
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)