Задать вопрос
23 мая, 23:23

Заполните массив 12 случайными целыми числами из промежутка [-10,10]. Выведите на экран элементы массива через пробел. Найдите сумму элементов массива, находящихся на четных позициях

+5
Ответы (1)
  1. 24 мая, 01:01
    0
    Var x, s, sum, i:integer;

    mass:array[1 ... 12] of integer;

    begin

    x:=0;

    sum:=0;

    for i:=1 to 12 do

    begin

    x:=x+1;

    s:=random (3) ;

    if (s mod 2) = 0

    then mass[i]:=random (11)

    else mass[i]:=-random (11) ;

    if (x mod 2) = 0 then sum:=sum+mass[i];

    write (mass[i]+' ') ;

    end;

    writeln ('') ;

    writeln ('сумма чисел на четных местах = '+sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Заполните массив 12 случайными целыми числами из промежутка [-10,10]. Выведите на экран элементы массива через пробел. Найдите сумму ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
С # 1. Создайте одномерный массив с 31 элементов, которые заполните случайными целыми числами от 11 до 100-11. Выведите значения элементов массива в строку, разделив их пробелами, 11 нечетное число.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Помогите выполнить задание на кумире: Массив из 15 элементов заполните целыми случайными числами из промежутка [0; 100]. Выведите его на экран. Замените значение второго и предпоследнего элементов на 0 и снова выведите массив на экран.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)