Задать вопрос
7 февраля, 07:02

Уменьшите данное число (х) в 2 раза если оно четное! информатика

+2
Ответы (1)
  1. 7 февраля, 07:50
    0
    Var

    x:integer;

    begin

    readln (x) ;

    if x mod 2=0 then x:=x div 2;

    writeln (x) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Уменьшите данное число (х) в 2 раза если оно четное! информатика ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Имеется исполнитель "Двоечка", имеющий следующую последовательность команд: 1. Удваивает данное число. 2. Прибавляет к данному числу 2, если данное число четное и вычитает из данного числа 2, если данное число нечетное. 3.
Ответы (1)
Помогите написать в паскале! Ввести три целых числа x, y, z. Если хотя бы одно из них четное, то первому четному числу присвоить значение произведения этих чисел.
Ответы (1)
Составить программу, отгадывающее натуральное чётное число, загаданное пользователем. Ниже представлен рекомендуемый диалог во время работы программы: Загадайте натуральное чётное число Прибавьте к нему 4 Уменьшите на 6 Поделите на 2 Что у вас
Ответы (1)
Укажите правильное полное имя файла: А) Текстовый файл song. doc Б) d:/информатика/файлы/word. doc В) текстовый файл D:/информатика/файлы/programma Г) / информатика/файлы/photo. doc
Ответы (1)
Пользователь работал с каталогом c:/предметы/физика/текст. Сначала он поднялся на два уровня вверх и после этого спустился сначала в каталог информатика, а потом в каталог оценки. запишите полный путь каталога в котором оказался пользователь.
Ответы (2)