Задать вопрос
2 января, 04:58

Дан массив из, состоящий из 9 вещественных чисел. Все элементы массива с четными номерами заменить на их абсолютную величину

+1
Ответы (1)
  1. 2 января, 08:39
    0
    Var

    a:array [1 ... 9] of real;

    i:integer;

    begin

    for i:=1 to 9 do read (a[i]) ;

    a[2]:=abs (a[2]) ;

    a[4]:=abs (a[4]) ;

    a[6]:=abs (a[6]) ;

    a[8]:=abs (a[8]) ;

    for i:=1 to 9 do write (a[i],' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив из, состоящий из 9 вещественных чисел. Все элементы массива с четными номерами заменить на их абсолютную величину ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Нужна помощь! 1. дан массив состоящий из 5 случайных целых чисел от - 1 до 10. Все его элементы уменьшить на число 20. 2. дан массив состоящий из 8 вещественных чисел. все элементы с четными номерами уменьшить на 1, с нечетными-увеличить на 1.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
Дан массив целых чисел. Нумерация элементов начинается с 0. Выведите все элементы массива с четными номерами. Формат входных данных Сначала задано число N - количество элементов в массиве, N100. Далее через пробел записаны N чисел - элементы массива.
Ответы (1)
Сделайте в паскаль. Дан массив вещественных чисел. Вывести на экран новое состояние массива, в котором: a) Каждый отрицательный элемент заменить на его абсолютную величину; b) Все элементы с нечетными номерами заменить на их квадратный корень;
Ответы (1)