Задать вопрос
25 марта, 11:07

Задача 1. Дан вес груза в килограммах (четырехзначное натуральное число). Найти количество полных тонн в нем и вывести на экран.

Задача 2. У трехзначного натурального числа справа зачеркнули одну цифру, какое число получилось? Вывести получившееся число на экран.

Задача 3. (повышенной сложности, по желанию) У двузначного натурального числа приписали разряд сотен справа. Вывести получившееся число на экран. (Например: было число 123, приписали 1 справа, получилось число 1231.)

+1
Ответы (1)
  1. 25 марта, 12:57
    0
    1.

    алг

    нач

    цел а

    ввод а

    вывод div (a, 1000), 'тонн'

    кон

    2.

    var x, i: integer;

    begin

    write ('Введите трёхзначное число: ') ;

    readln (x) ;

    if (x 100) then writeln ('Число не трёхзначное!')

    else

    begin

    i : = x mod 10; write (i)

    write (x div 100) ;

    write (x div 10 mod 10) ;

    end;

    end.

    3.

    Было число ав

    Стало число 2 ав2

    Разложим его на разряды

    2 ав2=2*1000+а*100+в*10+2=2002+100 а+10 в

    По условию задачи это в 32 раза больше исходного двузначного числа ав, т. е.:

    32 ав=2 ав2 (Число ав тоже разложим на разряды, получим 10 а+в)

    32 (10 а+в) = 2002+100 а+10 в

    32 (10 а+в) = 2002+10 (10 а+в)

    32 (10 а+в) - 10 (10 а+в) = 2002

    22 (10 а+в) = 2002

    10 а+в=2002:22

    10 а+в=91

    Итак, искомое число 91
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача 1. Дан вес груза в килограммах (четырехзначное натуральное число). Найти количество полных тонн в нем и вывести на экран. Задача 2. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль. 1) Дано трехзначное число, нужно найти число, полученное при прочтении его цифр справа налево. 2) Дано трехзначное число. В нем зачеркнули последнюю справа цифру и приписали ее в начале. Найти полученное число. 3) Дано трехзначное число.
Ответы (1)
В трехзначном числе x зачеркнули его вторую цифру. Когда к образовавшемуся двухзначному числу справа приписали вторую цифру числа x, то получилось число n. По заданному n найти число x (значение n вводится с клавиатуры).
Ответы (1)
Помогите, с помощью паскаля надо сделать следующее: Составить программу, решающую следующую задачу: дано трехзначное число. В нем зачеркнули первую цифру слева и приписали ее справа. Вывести полученное число.
Ответы (1)
Дано четырехзначное число в нем зачеркнули последнюю цифру и приписали ее в начало числа. Найти его, и записать в программе Pascal. (число любое)
Ответы (1)
Pascal. Тема: Циклы С клавиатуры вводится целое произвольное число 1) Вывести на экран первую и последнюю цифру числа. 2) Вывести на экран наибольшую цифру числа 3) Вывести на экран нечетные цифры этого числа
Ответы (2)