Задать вопрос
9 марта, 22:37

Целое число вводится с клавиатуры поменять местами первую и последнию цифры, например (3767, 7763).

Задача в Paskal ABC

+1
Ответы (1)
  1. 10 марта, 00:46
    0
    var N: string;

    m: char;

    i, D: byte;

    begin

    write (' N = ') ;

    readln (N) ;

    writeln;

    D : = Length (N) ;

    N m : = n[1];

    n[1] : = n[D];

    n[D] : = m;

    write (' Результат: ') ;

    for i : = 1 to D do

    write (n[i])

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Целое число вводится с клавиатуры поменять местами первую и последнию цифры, например (3767, 7763). Задача в Paskal ABC ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
С клавиатуры вводится целое число n. найти произведение всех цифр этого числа а так же колличество больших шестс клавиатуры вводится целое число n. найти произведение всех цифр этого числа а так же колличество больших шестии
Ответы (1)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
Построить алгоритм. С клавиатуры вводится трехзначное число А. поменять местами первую и последнюю цифры в этом числе.
Ответы (1)