Задать вопрос
8 июня, 11:55

I. Решить задачу на обработку линейного массива.

Найти сумму минимального и первого отрицательного элемента. Если отрицательных элементов нет, сообщить об этом.

Паскаль.

+5
Ответы (1)
  1. 8 июня, 13:50
    0
    Program Massiv;

    var

    a: array [1 ... 25] of integer;

    i: integer;

    min: integer;

    otr: integer;

    begin

    {Формирование массива случайными числами в заданном диапазоне}

    randomize;

    for i:=1 to 25 do

    a[i]:=random (201) - 100;

    min:=a[1];

    otr:=1;

    for i:=1 to 25 do

    begin

    if a[i]
    if (a[i]<0) and (otr=1) then otr:=a[i];

    end;

    if otr=1 then

    writeln ('Отрицательных элементов не найдено')

    else

    writeln (otr+min)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «I. Решить задачу на обработку линейного массива. Найти сумму минимального и первого отрицательного элемента. Если отрицательных элементов ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1. Дан массив 1 2 3 4 5 6 7 8 7 0 - 8 - 4 2 16 - 10 2 А Определите: А) размерность массива; Б) значение элемента А[3]; В) значение максимального элемента массива; Г) индекс первого отрицательного элемента массива;
Ответы (1)
Написать программу, позволяющую для заданного одномерного массива А из n вещественных или целых элементов реализовать обработку массива. Длина массива N задается пользователем как константное выражение.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Что определяет для массива X[1 ... n] следующий алгоритм P: = 0; For k: = 1 to n do If X[k]
Ответы (1)