Задать вопрос
27 сентября, 12:22

2) Заполнить массив А случайными целыми числами разных знаков. Составить программу вывода на экран номеров элементов массива, равных максимальному.

+1
Ответы (1)
  1. 27 сентября, 15:46
    0
    Var mas: array[-1000 ... 1000] of integer;

    i, max, n: integer;

    begin

    {ввод количества элементов массива}

    readln (n) ;

    {ввод массива и его вывод на экран}

    randomize;

    for i : = 1 to n do

    begin

    mas[i] : = 50 - random (100) - 1;

    write (mas[i]:5) ;

    if (i mod 10 = 0) then writeln;

    end;

    {поиск максимума}

    max : = mas[1];

    for i : = 2 to n do

    if (mas[i] > max) then max : = mas[i];

    {нахождение номеров элементов массива}

    writeln;

    for i:=1 to n do if (mas[i] = max) then write (i,' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «2) Заполнить массив А случайными целыми числами разных знаков. Составить программу вывода на экран номеров элементов массива, равных ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)