Задать вопрос
9 апреля, 22:45

1) Напишите программу в Паскале

Заполнить массив случайными целыми числами. Заменить элементы массива, кратные K нулями, остальные 1 (К ввести с клавиатуры)

+3
Ответы (1)
  1. 9 апреля, 23:19
    0
    var

    mas: array[-1000 ... 1000] of integer;

    i, k, n: integer;

    begin

    {ввод количества элементов массива}

    readln (n) ;

    {ввод числа к}

    readln (k) ;

    {ввод массива и его вывод на экран}

    randomize;

    for i : = 1 to n do

    begin

    mas[i] : = 50 - random (100) - 1;

    write (mas[i]:4) ;

    if (i mod 10 = 0) then writeln;

    end;

    {замена элементов массива}

    writeln;

    for i:=1 to n do begin

    if (mas[i] mod k=0) then mas[i]:=0

    else

    mas[i]:=1;

    write (mas[i]:4) ;

    if (i mod 10 = 0) then writeln;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1) Напишите программу в Паскале Заполнить массив случайными целыми числами. Заменить элементы массива, кратные K нулями, остальные 1 (К ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)
1. Заполнить массив а [1 ... 14] случайными целыми числами в диапазоне от 1 до 18 и вывести на экран элементы массива с нечетными значениями, меньшими 10. 2. Заполнить массив а [1 ...
Ответы (1)
А) Составьте программу, которая заполняет массив В[1 ... 11] случайными целыми числами в диапазоне от - 5 до 5 и преобразовывает его, заменяя элементы кратные 5 на 5, а остальные увеличивая в 5 раз.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)