Задать вопрос
12 марта, 12:09

Написать программу которая задает массив случайным образом и ищет минимальный элемент

+5
Ответы (1)
  1. 12 марта, 12:38
    0
    Const n=10;

    var a:array[1 ... n] of integer;

    min, i:integer;

    begin

    Randomize;

    for i:=1 to n do begin

    a[i]:=random (51) ;

    write (a[i],' ') ;

    end;

    writeln;

    min:=a[1];

    for i:=2 to n do

    if a[i]
    writeln ('min = ', min) ;

    end.

    Пример:

    26 23 27 25 35 8 40 17 43 23

    min = 8
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу которая задает массив случайным образом и ищет минимальный элемент ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. заполните одномерный массив B1 размерностью в N (< 30 задает пользователь при выполнении программы) элементов так, чтобы каждый элемент с четным номером был равен половине своего номера, а каждый элемент с нечетным номером - количеству элементов
Ответы (1)
1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива. 2.
Ответы (2)
Паскаль! Заполните массив случайными числами и найти минимальный и максимальный элементы массива и их номера. Пример: Массив: 1 2 3 4 5 Минимальный элемент: A[1]=1 Максимальный элемент: A[5]=5
Ответы (1)
Заполнить массив случайными числами и найти минимальный и максимальный элементы массива и их номера Пример: Массив: 1 2 3 4 5 Максимальный элемент: А[1]=1 Минимальный элемент: А[5]=5 10 класс
Ответы (1)
Задать массив размерности 25 случайным образом от - 10 до 9. Поменять местами первый минимальный и последний максимальный элементы массива. Вывести первоначальный массив и получившийся массив. Помогите решить в паскале
Ответы (1)