Задать вопрос
10 ноября, 18:31

В управляющий совет школы входят родители, учителя и учащиеся школы, причём родителей должно быть не менее одной трети от общего числа членов совета. В настоящий момент в совет входит N человек, из них K родителей. Определите, сколько родителей нужно дополнительно ввести в совет, чтобы их число стало составлять не менее трети от числа членов совета.

Программа получает на вход два целых числа N и K (N > 0, 0 ≤ K ≤ N ≤ 2⋅109), записанные в отдельных строках, - текущее число членов совета и число родителей в совете.

Программа должна вывести единственное число - минимальное число родителей, которое необходимо ввести в совет.

Ввод Вывод

27

7 3

Пример 2

Ввод Вывод

1

0 1

Пример 3

Ввод Вывод

7

1 2

+5
Ответы (1)
  1. 10 ноября, 20:58
    0
    Если "родителей должно быть не менее одной трети" (т. е. больше или равно), то в первом примере (где n=27, k=7) ответ должен быть 2, а не 3. 7+2=9 - это как раз 1/3 от 27.

    var n, k, m:integer;

    begin

    writeln;

    readln (n) ;

    readln (k) ;

    m: = (n-1) div 3+1;

    if m-k>0 then writeln (m-k) else writeln (0) ;

    end.

    Пример:

    27

    7

    2
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В управляющий совет школы входят родители, учителя и учащиеся школы, причём родителей должно быть не менее одной трети от общего числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В Python С клавиатуры вводится натуральное число. Программа должна вывести следующее за ним четное число. Например, если ввести 7, то программа должна вывести 8, а если ввести 8, то программа должна вывести 10.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
Разделите точками цифры этого числа группами по три, начиная справа. Программа получает на вход натуральное число, содержащее не более 100 цифр. Программа должна вывести то же число, с точками между некоторыми цифрами этого числа.
Ответы (1)
Задача 2. Напишите программу, которая в последовательности натуральных чисел определяет минимальное чётное число. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется четное число.
Ответы (1)