Задать вопрос
26 октября, 23:14

Pascal. Составить программу, в которой с помощью оператора while посчитать сумму ряда тех пор пока член ряда не будет меньше 0.005.

+2
Ответы (1)
  1. 27 октября, 02:37
    0
    Const e=0.005;

    var i:integer;

    a, s:real;

    begin

    i:=2;

    a:=5 / (i*i-1) ;

    s:=0;

    while a>=e do

    begin

    s:=s+a;

    i:=i+1;

    a:=5 / (i*i-1) ;

    end;

    writeln ('i = ', i,' s = ', s) ;

    end.

    Результат:

    i = 32 s = 3.59122983870968
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Pascal. Составить программу, в которой с помощью оператора while посчитать сумму ряда тех пор пока член ряда не будет меньше 0.005. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Вводятся целые тор числа по одному, до тех пор пока не будет введен 0. Посчитать количество четных чисел. Язык Паскаль. Использовать оператор while
Ответы (1)
1. Составьте программу в Pascal ABC. Даны три числа. Найти сумму двух наибольших из них. 2. Составьте программу в Pascal ABC.
Ответы (1)
Написать программу 4. Компьютер перебирает четные числа до тех пор, пока сума их квадратов не превысит S. Чему равна сумма квадратов? Подсказка: Начальное значение переменной цикла - 2. Шаг изменения - 2 (перебираем четные числа).
Ответы (1)