Задать вопрос
20 января, 18:47

В книге на одной странице помещается K строк. Таким образом, на 1-й странице печатаются строки с 1-й по K-ю, на второй - с (K+1) - й по (2∙K) - ю и т. д. Напишите программу, которая по номеру строки в тексте определяет номер страницы, на которой будет напечатана эта строка, и порядковый номер этой строки на странице.

+4
Ответы (1)
  1. 20 января, 20:53
    0
    Пусть нужно узнать, где будет напечатана строка с номером n. Для предыдущих (n - 1) строк нужно (n - 1) div k полных страниц и ещё (n - 1) mod k строк на ((n - 1) div k + 1) - ой странице. n-я строка будет следующей на этой странице.

    var

    n, k, fullPages, restLines: integer;

    begin

    write ('Номер строки: ') ;

    readln (n) ;

    write ('Строк на странице: ') ;

    readln (k) ;

    fullPages : = (n - 1) div k;

    restLines : = (n - 1) mod k;

    writeln ('Страница: ', fullPages + 1, ', строка: ', restLines + 1) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В книге на одной странице помещается K строк. Таким образом, на 1-й странице печатаются строки с 1-й по K-ю, на второй - с (K+1) - й по ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Синвейн про информатику (1 строка информатика 2 строка два прилагательных 3 строка три глагола 4 строка фраза, несущая определённый смысл 5 строка вывод в одном слове) Стоки не должны рифмоваться
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Паскаль 1) Задана строка, проверить есть ли в этой строке буква "а" 2) задана строка, проверить сколько раз встречаться в этой строке буква "м" 3) задана строка, удалить из этой строки все буквы "и"
Ответы (1)
1) Напишите программу, которая определяет, верно ли, что введенное число состоит из одинаковых цифр (например, 222) 2) Напишите программу, которая определяет, верно ли, что введеное число содержит две одинаковые цифры, стоящие рядом (например, 221)
Ответы (1)
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)