Задать вопрос
17 октября, 01:58

Найти количество цифр равных K в заданном натуральном числе

+2
Ответы (1)
  1. 17 октября, 03:04
    0
    int n, k, ans = 0; cin >> n >> k; while (n! = 0) { if (n % 10 = = k) ans++; n = n / 10; } cout << ans;
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти количество цифр равных K в заданном натуральном числе ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
написать программу на языке паскаль, которая считывает с клавиатуры строку S, состоящую из цифр. В заданном строкой S натуральном N-разрядном числе упорядочить цифры так, чтобы получить наибольшее число, записанное теми же цифрами.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Напишите рекурсивную функцию подсчёта количества цифр в натуральном числе. Формат входных данных На вход ваша программа получает одно натуральное число n (1≤n≤216-11≤n≤216-1). Формат выходных данных Выведите одно число - количество цифр в числе n.
Ответы (2)
Помогите решить. В заданном натуральном трехзначном числе имеется четная цифра. Pascal
Ответы (1)
В заданном целом положительном числе N (0 < N < 2^10) удалите все четные цифры не нарушая последовательности цифр в числе. в паскале
Ответы (1)