Задать вопрос
27 августа, 22:00

Спомощью датчика случайных чисео ввести 4 значения от - 47 до 16. Найти максимум и уменьшить на 5

+3
Ответы (1)
  1. 28 августа, 00:32
    0
    Program p1;

    var i, max:integer;

    a:array[1 ... 4] of integer;

    begin

    max:=-18;

    randomize;

    for i:=1 to 4 do a[i]:=random (63) - 47;

    for i:=1 to 4 do write (a[i],' ') ;

    writeln;

    for i:=1 to 4 do

    begin

    if a[i]>max then max:=a[i];

    end;

    write (max-5) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Спомощью датчика случайных чисео ввести 4 значения от - 47 до 16. Найти максимум и уменьшить на 5 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) С помощью датчика случайных чисел получить к-вещественных чисел n (0
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
1) напишите программу формирования массива размеров 5 х 5 с помощью датчика случайных чисел. замените в нем все четные значения элементов суммой индексов элементов главной диагонали.
Ответы (1)
1. Переведите на язык программирования: а) ввести А и С увеличить А в 10 раз уменьшить С в 20 раз напечатать модуль разности А и С б) ввести А и С если А>С, то увеличить А в 5 раз иначе уменьшить С в 2 раза напечатать значения А и С конец в) ввести
Ответы (1)
1) напишите программу формирования массива размером 5 х5 с помощью датчика случайных чисел. найдите максимальное значение элементов и замените последний элемент каждой строки этим значением.
Ответы (1)