Задать вопрос
6 января, 09:06

Помогите написать программу, которая переводит мм в дюйм, путем деления. (в одном дюйме 0.0394 мм)

+2
Ответы (1)
  1. 6 января, 10:26
    0
    1 мм = 0,0393701 дюйма!

    1 дюйм = 25.4 мм

    1)

    var m, d:real;

    begin

    write ('Введите длину (в мм) : ') ;

    readln (m) ;

    d:=m*0.0394;

    writeln (m,' мм = ', d:8:4,' дюйма (ов) ') ;

    end.

    2)

    var m, d:real;

    begin

    write ('Введите длину (в мм) : ') ;

    readln (m) ;

    d:=m/25.4;

    writeln (m,' мм = ', d:8:4,' дюйма (ов) ') ;

    end.

    Пример:

    Введите длину (в мм) : 5

    5 мм = 0.1970 дюйма (ов)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу, которая переводит мм в дюйм, путем деления. (в одном дюйме 0.0394 мм) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу которую сменяют длину N см на фут и дюйм. Для справки: 1 дюйм = 2,54; 1 фут = 12 дюйм
Ответы (1)
Составить программу, которая находит минимальное натуральное число х, такое, что остаток от деления х на 10 равен 9, остаток от деления х на 9 равен 8, остаток от деления х на 8 равен 7, ... остаток от деления х на 2 равен 1.
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
Вася написал программу, которая переводит длину из метров в километры и метры. Но он не может решить, где нужно использовать div, а где mod. Помогите ему. Откройте файл и исправьте программу.
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)