Задать вопрос
1 августа, 03:29

Дан массив из 16 целых чисел, заполнить его так что бы первый был равен 1, второй - 2 а каждый следующий сумме двух предыдущих

+4
Ответы (1)
  1. 1 августа, 06:28
    0
    Var i:integer;

    a:array [1 ... 16] of integer;

    begin

    a[1]:=1;

    a[2]:=2;

    for i:=3 to 16 do

    a[i]:=a[i-1]+a[i-2];

    for i:=1 to 16 do

    write (a[i],' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив из 16 целых чисел, заполнить его так что бы первый был равен 1, второй - 2 а каждый следующий сумме двух предыдущих ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество. 2. Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Даны два целых числа A и B (A < B). Найти сумму всех чисел от A до B включительно. 2. Даны два целых числа A и B (A 0). Найти произведение всех чисел от A до B включительно. 3. Дан массив целых чисел Х. Найти сумму квадратов всех чисел. 4.
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)