Задать вопрос
9 января, 17:25

Даны оценки ученика по n предметам. Требуется определить общее количество пятерок и четверок.

Формат входных данных

На первой строке входного файла записано натуральное число nn (n≤100) (n≤100) - количество оценок. На следующей строке через пробел записаны оценки ученика - целые числа от 11 до 55.

Формат выходных данных

Требуется вывести искомое число.

Примеры

входные данные:

3

4 5 3

выходные данные:

2

+2
Ответы (1)
  1. 9 января, 19:28
    0
    Var

    i, c, n: integer;

    ar: array[1 ... 10000]of integer;

    begin

    c : = 0;

    readln (n) ;

    for i : = 1 to n do

    begin

    read (ar[i]) ;

    if (ar[i] = 4) or (ar[i] = 5) then c : = c + 1;

    end;

    write (c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны оценки ученика по n предметам. Требуется определить общее количество пятерок и четверок. Формат входных данных На первой строке ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан массив a из n целых чисел. Требуется вывести только неотрицательные числа. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)
Дан массив a из n целых чисел. Требуется вывести только элементы с четными значениями. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)
Дан массив a из n целых чисел. Требуется сначала вывести все четные элементы, затем - нечетные. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)
Дан массив a из n целых чисел. Требуется сначала вывести элементы, стоящие на четных местах, затем - на нечетных. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)
Дан массив aa из nn целых чисел. Требуется определить, превосходит ли 100 сумма элементов, которые больше 20. Формат входных данных На первой строке входного файла записано натуральное число nn (n≤100) (n≤100) - число элементов в массиве.
Ответы (1)