Задать вопрос
11 апреля, 01:20

Составе программу, которая заполняет массив b[1 ... 8] случайными целыми числами в диапазоне от 1 до 10 и находит произведение элементов с нечестными значениями и количество элементов с чётными значениями.

+2
Ответы (1)
  1. 11 апреля, 03:18
    0
    Var

    i, c, p: integer;

    ar: array[1 ... 8]of integer;

    begin

    c : = 0;

    p : = 1;

    for i : = 1 to 8 do

    begin

    ar[i] : = random (1, 10) ;

    write (ar[i], ' ') ;

    if (ar[i] mod 2 = 0) then c : = c + 1

    else p : = p * ar[i];

    end;

    writeln;

    writeln (p) ;

    writeln (c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составе программу, которая заполняет массив b[1 ... 8] случайными целыми числами в диапазоне от 1 до 10 и находит произведение элементов с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
1. Cоставьте программу, которая заполняет массив a [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с чётными значениями на 1.
Ответы (1)
1) Составте программуб которая заполняет массив а[1 ... 10] случайными целыми числами в диапозоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с четными значениями на 1.
Ответы (1)
Составьте программу которая заполняет массив b1 ... 8 случайными целыми числами в диапазоне от 1 до 10 и находит произведение элементов с нечетными значениями и количеством элементов с четными значениями помогите хоть каким решением
Ответы (1)