Задать вопрос
15 января, 16:30

Вася с Петей и Колей заработали много денег. Чтобы не мучиться с дележкой, они решили, что сначала Вася заберет все купюры максимального достоинства, затем Петя - минимального, а все оставшиеся - Коля Помогите рассчитать, кто сколько купюр получит.

Формат входных данных

В первой строке содержится число N (1 ≤ N ≤ 1000000) - количество купюр. Во второй строке записано N натуральных чисел, не превосходящих 109 - номиналы купюр.

Формат выходных данных

Выведите через пробел три числа: сколько купюр достанется Васе, Пете и Коле соответственно.

Пример

input. txt | output. txt

4 |

1 2 3 4 | 1 1 2

5

2 2 4 4 4 | 3 2 0

+4
Ответы (1)
  1. 15 января, 19:13
    0
    program delehka (input, output) ;

    var a:Array[1 ... 1000010] of longint;

    i, n, s, ma, mi, sl:longint;

    begin

    assign (input,'input. txt') ;

    reset (input) ;

    assign (output,'output. txt') ;

    rewrite (output) ;

    readln (n) ;

    mi: = (1 shl 30) ;

    ma: = - (1 shl 30) ;

    for i:=1 to n do begin read (a[i]) ;

    ma:=max (ma, a[i]) ;

    mi:=min (mi, a[i]) ;

    end;

    if ma=mi then write (0,'', n,'',0)

    else

    begin for i:=1 to n do

    begin

    if a[i]=ma then s:=s+1;

    if a[i]=mi then sl:=sl+1;

    end;

    writeln (s,' ', sl,' ', n-s-sl) ;

    close (input) ;

    close (output) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вася с Петей и Колей заработали много денег. Чтобы не мучиться с дележкой, они решили, что сначала Вася заберет все купюры максимального ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Задан полный путь к файлу C:/Мои документы/доклад. txt Каково полное имя файла? а) C: / Мои документы/доклад. txt б) Мои документы/доклад. txt в) доклад г) доклад. txt 2. Задан полный путь к файлу C:/Мои документы/доклад.
Ответы (2)
Написать программу в Паскале. По заданному числу N определите знак числа. Формат входных данных: Во входном файле input.
Ответы (1)
Даны два файла: input. txt и output. txt. В input. txt дана последовательность чисел: 1,6,11,16,21. В Output. txt отобразить размах ряда (т. е разность между наибольшим и наименьшим числом). Pascal
Ответы (1)
Нужно определить что в введеном числе 24 часовой формат или 12 часовой формат и составить код в с++ Задача такое: №1 Input (стандартный ввод) Output (вывод) 11:00 24-часовый формат 23:00 №2 Input (стандартный ввод) Output (вывод) 09:20 12-часовый
Ответы (1)
Дан массив a из n целых чисел. Требуется сначала вывести все четные элементы, затем - нечетные. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)