Задать вопрос
4 декабря, 21:42

Вводится последовательность не нулевых чисел. Ноль конец последовательности. Определить сколько раз последовательность меняет знак

+2
Ответы (1)
  1. 4 декабря, 22:52
    0
    Program m;

    Var old, new: real;

    k, n, i: integer;

    Begin

    repeat

    write ('vvod posl n = ') ;

    readln (n)

    until n>0;

    Write ('vvod x = ') ;

    Readln (old) ;

    k:=0;

    for i:=2 to n do

    begin

    Write ('vvod x = ') ;

    Readln (new) ;

    If new*old<0 then k:=k+1;

    Old:=new;

    end;

    If k>0 then

    Writeln ('posledovatelnost menyaet znak ', k, ' raz')

    Else Writeln ('posledovatelnost ne menyaet znak') ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вводится последовательность не нулевых чисел. Ноль конец последовательности. Определить сколько раз последовательность меняет знак ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Вводится последовательность целых ненулевых чисел, 0 - конец последовательности. Определить, сколько раз последовательность поменяет знак. Ограничения! Нельзя использовать условный оператор (If) и оператор выбора (Case).
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Вводится последовательность из n произвольных чисел. Определить, сколько раз последовательность меняет знак.
Ответы (1)
Вводится последовательность натуральных чисел. Ноль - при-знак конца. Подсчитайте, сколько раз в этой последовательности встре-чается максимальное число, и выдайте полученный результат.
Ответы (1)
Составьте программу на языке Паскаль для следующих задач: 1. Найдите сумму всех чисел от a до 500 (значение a вводится с клавиатуры; a≤500). 2. Найдите среднее арифметическое всех целых чисел от a до b (значение a и b вводится с клавиатуры; a≤b). 3.
Ответы (1)