Задать вопрос
12 декабря, 16:12

Нужно написать программу на языке Паскаль условие такое:

вводится 15 чисел определить каких чисел кратных трём больше положительных или отрицательных

+3
Ответы (1)
  1. 12 декабря, 18:36
    0
    Var a, p, n, i:integer;

    begin

    p : = 0;

    n : = 0;

    for i : = 1 to 15 do

    begin

    read (a) ;

    if a mod 3 = 0 then

    if a > 0 then p : = p + 1

    else

    if a < 0 then n : = n + 1

    end;

    if p > n then writeln ('Положительных') else

    if p < n then writeln ('Отрицательных') else

    writeln ('Одинаково')

    end.

    {вариант "как-то посложнее"}

    var a, i, s:integer;

    begin

    s : = 0;

    for i : = 1 to 15 do

    begin

    read (a) ;

    s : = s + ord (a mod 3 = 0) * (ord (a > 0) - ord (a < 0))

    end;

    if s > 0 then writeln ('Положительных') else

    if s < 0 then writeln ('Отрицательных') else

    writeln ('Одинаково')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Нужно написать программу на языке Паскаль условие такое: вводится 15 чисел определить каких чисел кратных трём больше положительных или ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
1. с клавиатуры вводится n действительных чисел. Определить сколько в данной последовательности нечетных отрицательных чисел. 2. Составить программу на языке Паскаль вычисления кубов чисел вводимых с клавиатуры. 3.
Ответы (1)
Подсчитайте, сколько среди данных N чисел нулей, положительных чисел, отрицательных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число положительных и отрицательных чисел.
Ответы (1)