Задать вопрос
16 сентября, 12:38

Ввести n чисел. Верно ли что количество введённых отрицательных чисел не превышает 5.

В Паскале

+2
Ответы (1)
  1. 16 сентября, 14:22
    0
    Const

    n = 10;

    var

    i, d, k: integer;

    begin

    for i : = 1 to n do

    begin

    readln (d) ;

    if d < 0 then k : = k + 1;

    end;

    if k < = 5 then

    writeln ('правда')

    else

    writeln ('не правда') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ввести n чисел. Верно ли что количество введённых отрицательных чисел не превышает 5. В Паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программы на Паскале. 1. Вычислить. X - натуральное число. 2. Среди 10 введённых с клавиатуры чисел подсчитать количество отрицательных и произведение положительных. Рассмотреть случай если отрицательных чисел нет.
Ответы (1)
Написать программу в Паскале, которая определяет сумму натуральных чисел кратных 3 и оканчивающихся на 6. Последнее число последовательности 0. Количество чисел не превышает 1000. Количество введённых чисел неизвестно.
Ответы (1)
Задача в паскале среди 10 введенных с клавиатуры чисел подсчитать количество отрицательных и произведение положительных чисел рассмотреть случай когда положительных чисел нет
Ответы (1)
1. Ввести с клавиатуры длину и ширину прямоугольной двери. Кроме того, ввести длину, ширину и высоту шкафа - прямоугольного параллелепипеда. Выяснить, можно ли пронести шкаф через дверь, не разбирая его. 2. Ввести три вещественных числа с клавиатуры.
Ответы (1)
определить среди 3 введенных чисел (a, b, c) количество отрицательных и положительных. Если больше отрицательных то найти произведение этих 3 чисел, а иначе найти max из трех
Ответы (1)