Задать вопрос
27 февраля, 10:23

Дана последовательность целых чисел. Найти количество различных чисел в этой последовательности. Помогите с блок схемой через цикл while

+5
Ответы (1)
  1. 27 февраля, 11:01
    0
    Цикл в цикле ваша тема:

    program pin;

    var

    i, j, cm: Integer;

    povtor: Boolean;

    const

    m: array[1 ... 10] of Integer = (1, 2, 3, 1, 2, 5, 4, 3, 1, 2) ;

    begin

    cm : = 0;

    for i : = 1 to 10 do

    begin

    povtor : = False;

    for j : = 1 to 10 do

    begin

    if (i j) and (m[ i ] = m[ j ]) then

    begin

    povtor : = True;

    Break;

    end;

    end;

    if not povtor then cm : = cm + 1;

    end;

    WriteLn (cm) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана последовательность целых чисел. Найти количество различных чисел в этой последовательности. Помогите с блок схемой через цикл while ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Сколько раз будет выполнен этот цикл? i:=2; while i
Ответы (2)
Дана последовательность операторов: A:=1; B:=2; While A+B
Ответы (1)