Задать вопрос
23 апреля, 07:27

Напишите программу подсчета количества и суммы нечетных элементов массива

+5
Ответы (2)
  1. 23 апреля, 08:15
    0
    Код Pascal 1 2 3 4 5 6 7 8 9 10 11 12 begin var Size : = ReadLnInteger ('Размер массива = ') ; var A : array of Integer; SetLength (A, Size) ; for var i : = 0 to pred (Size) do A[i] : = ReadLnInteger ('A[' + (i+1). ToString + '] = ') ; WriteLn ('Введён массив A = ', A) ; var count : = 0; for var i : = 0 to pred (Size) do if Not odd (A[i]) then count + = 1; WriteLn ('В массиве чётных элементов: ', count) ; var max : = 0; for var i : = 1 to pred (Size) do if A[max] < A[i] then max : = i; var k : = ReadLnInteger ('k = ') ; A[max] * = k; WriteLn ('Массив A = ', A) ; end.
  2. 23 апреля, 09:04
    0
    Если что нибудь нужно пояснить или изменить, пиши.

    const n=10; / / вместо 10 количество ячеек в массиве (любое)

    var a: array [1 ... n] of integer;

    i, k, s: integer;

    begin

    randomize;

    for i:=1 to n do begin

    a[i]:=random (100) ;

    if i mod 20 then

    begin k:=k+1; s:=s+a[i]; end; end;

    writeln (k,' ', S)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу подсчета количества и суммы нечетных элементов массива ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Напишите программу, которая фармирует масси из N элементов (максимальное количество элементов равно 20), значения элементов массива - случайные числа от - 10 до 25 Программа должна: 1) выводить на экран сначала все элементы массива, стоящие на
Ответы (1)
Составьте программу в Паскале для поиска: a) суммы положительных элементов массива от а от 1 до 100, введенных с клавиатуры b) произведения отрицательных элементов массива а от 1 до 100 c) количества нулевых элементов массива с сотней элементов
Ответы (1)