Задать вопрос
13 июня, 05:53

Написать программу печати чисел Фибоначчи от 1 до 1000, являющихся простыми числами, а также их порядковых номеров в ряду Фибоначчи.

Помогите с программой на паскале.

+5
Ответы (1)
  1. 13 июня, 06:27
    0
    Var f1, f2, s:longint; k:integer;

    function prost (n:longint) : boolean;

    var j, m:integer;

    begin

    m:=0;

    for j:=2 to trunc (sqrt (n)) do

    if n mod j = 0 then inc (m) ;

    prost:=m=0;

    end;

    begin

    f1:=1; f2:=1;

    writeln ('№ - Число') ;

    writeln ('1 - ', f1) ;

    s:=1; k:=2;

    while s<=1000 do

    begin

    if prost (s) then writeln (k,' - ', s) ;

    inc (k) ;

    s:=f1+f2;

    f1:=f2;

    f2:=s;

    end;

    end.

    Результат:

    № - Число

    1 - 1

    2 - 1

    3 - 2

    4 - 3

    5 - 5

    7 - 13

    11 - 89

    13 - 233
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу печати чисел Фибоначчи от 1 до 1000, являющихся простыми числами, а также их порядковых номеров в ряду Фибоначчи. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите задачу на Паскале. Числа Фибоначчи определяются как а (0) = 1, а (1) = 1, а (i) = a (i-1) + a (i-2). Найти десятое число Фибоначчи. Найти : a) N-ое число Фибоначчи б) Сумму первых N чисел Фибоначчи
Ответы (1)
Дата рождения. Профессор Бит Байтович Алгоритмович черезвычайно гордится своим гениальным, по его мнению сыном.
Ответы (1)
Последовательность Фибоначчи определяется следующим образом: первые два члена последовательности равны 1, а каждый следующий равен сумме двух предыдущих. То есть числами Фибоначчи являются 1,1,2,3,5,8,13, ... Вводится натуральное число.
Ответы (1)
Последовательностью Фибоначчи называется последовательность чисел a0, a1, ..., an, ..., где a0 = 0, a1 = 1, ak = ak-1 + ak-2 (k > 1). Требуется найти N-е число Фибоначчи. Примечание. В программе запрещается использовать циклы.
Ответы (1)
Задача А Число Фибоначчи это числовая последовательность, в которой первые два числа единицы, а каждое последующее равно сумме двух предыдущих. Дано натуральное число N (2< N < 2*10^9). Найти два ближайших к нему числа Фибоначчи.
Ответы (1)