Задать вопрос
20 сентября, 03:07

Не могу составить программу, уже весь мозг перевернул, помогите через Pascal

Присвоить целой переменной d четвертую от конца цифру в записи

положительного целого числа x (например, если x=34517, то d=4)

+2
Ответы (1)
  1. 20 сентября, 06:50
    0
    Program Project;

    uses

    crt;

    var

    x, d: integer;

    begin

    clrscr;

    write ('x=') ;

    readln (x) ;

    d: = (x div 1000) mod 10;

    writeln ('d=', d) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Не могу составить программу, уже весь мозг перевернул, помогите через Pascal Присвоить целой переменной d четвертую от конца цифру в записи ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан алгоритм: Начало Присвоить a значение 1 Присвоить b значение 1 Присвоить c значение 0 Пока a меньше чем 1001 Начало цикла Присвоить b значение b * a Присвоить a значение a + 1 Конец цикла Пока b делится на 6 Начало цикла Присвоить c значение c +
Ответы (1)
Опишите переменные для размещения в них: - пола человека (один символ) ; - целого положительного двузначного числа; -целого положительного трёхзначного числа; -целого положительного четырёхзначного числа; -небольшого вещественного числа;
Ответы (1)
Даны две числовые переменные a и b. Необходимо присвоить переменной a значение переменной b, переменной b необходимо присвоить значение переменной a, без использования дополнительных переменных.
Ответы (1)
Даны две переменные целого типа: A и B. Если их значения не равны, то присвоить каждой переменной максимальное из этих значений, а если равны, то присвоить переменным нулевые значения.
Ответы (1)
Даны 2 переменные целого типа а и в если их значения не равны, то присвоить каждой переменной сумму этих значений, а если равны, то присвоить пременным нулевые значения. вывести новые значения а и в
Ответы (1)